Patchfirst
CVE-2023-50719 Public exploit High · 7.5 EPSS 83.5%

XWiki Platform Solr search discloses password hashes of all users

xwiki · xwiki-platform

Summary

The XWiki Platform (xwiki-platform) has a flaw in its Solr-based search component that exposes users' password hashes and, for extensions storing secrets such as API keys in their configuration, those values as plain text. An unauthenticated remote attacker with view rights on user profiles (which are public by default) can obtain these via search, with no user interaction required.

Official description · CVE.org

XWiki Platform is a generic wiki platform. Starting in 7.2-milestone-2 and prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, the Solr-based search in XWiki discloses the password hashes of all users to anyone with view right on the respective user profiles. By default, all user profiles are public. This vulnerability also affects any configurations used by extensions that contain passwords like API keys that are viewable for the attacker. Normally, such passwords aren't accessible but this vulnerability would disclose them as plain text. This has been patched in XWiki 14.10.15, 15.5.2 and 15.7RC1. There are no known workarounds for this vulnerability.

Breakdown
30.2 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 15 Dec 2023. No public exploit code or confirmed exploitation is recorded.

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-search-solr-api.

Mavenorg.xwiki.platform:xwiki-platform-search-solr-apiGHSA-p6cp-6r35-32mh

Upgrade to 15.5.2

Fixes this CVE and 1 other known vulnerability in this package (CVE-2023-50720).

Also affected, despite being newer: 15.6-rc-1 up to 15.7-rc-1.

Set the version to 15.5.2 or later in your pom.xml or build.gradle.

The first fix for CVE-2023-50719.

Affected versions, by release line

If you runUpgrade to
15.6-rc-1 up to 15.7-rc-115.7-rc-1
15.0-rc-1 up to 15.5.215.5.2
7.2-milestone-2 up to 14.10.1514.10.15

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close