Upgrade to 2.555.3 or later
Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2024-23897, CVE-2025-59474, +1).
Set the version to 2.555.3 or later in your pom.xml or build.gradle.
First fixed in 2.442 for CVE-2024-23898.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 2.427 up to 2.442 | 2.555.3first fix for this CVE: 2.442 |
| 2.217 up to 2.426.3 Still affected on this line by CVE-2025-59474 (fixed in 2.516.3, a newer line); CVE-2026-53435 (fixed in 2.555.3, a newer line). | 2.426.3 |
“Up to” means the second version is the fix and is not affected.