GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost
geoserver · geoserver
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. It possible to achieve Service Side Request Forgery (SSRF) via the Demo request endpoint if Proxy Base URL has not been set. Upgrading to GeoServer 2.24.4, or 2.25.2, removes the TestWfsPost servlet resolving this issue.
- Exploited
- Yes, in VulnCheck KEV
- Reports
- 0
- Tactics
- 0/15
Exploitation timelineDated milestones for a CVE: when it was disclosed, when exploit code became public, when exploitation was confirmed, and when threat reports named it.
First seen exploited 51 days after disclosure.
- Disclosedday 0
- First seen exploitedVulnCheck KEV evidence+51 days
Patch historyEarlier and later CVEs in the same code, in date order. It shows when a fix was bypassed or incomplete and which version finally fixed it.
2 related vulnerabilities in the same code over 3 years. The latest fix listed for gs-wfs is 2.27.1.
Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.
relatedHigh
Why these are linked: Link confidenceHow strong the evidence is that two CVEs are related. High: stated in the CVE text or linked in an advisory, or the same code was patched one release apart. Medium: the same code, or a version step plus a similar description. Low: similar description only.
- Linked in OSV/GitHub advisoryGHSA-5gw5-jccf-6hxw
This CVECVE-2024-29198GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost10 Jun 2025
Fixes in gs-wfsMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.
- 2.20.4CVE-2023-3504212 Jun 2023
- 2.25.2CVE-2024-364011 Jul 2024KEV
- 2.25.2CVE-2024-2919810 Jun 2025
- 2.27.1CVE-2025-3022010 Jun 2025Latest listed
MITRE ATT&CKA public catalogue of the techniques attackers use, maintained by MITRE. Patchfirst uses it to describe what attackers do with a vulnerability. techniques
No techniques linkedNo ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.
Am I affected? What do I upgrade to?
From GitHub Security Advisories and OSV2 packages in 1 ecosystem. No single main package: each of these ships the affected code.
- Mavenorg.geoserver:gs-wfsAffected: 2.25.0 up to 2.25.2; 2.0.0 up to 2.24.4Upgrade to 2.25.7 or later (older lines: 2.24.4)
- Mavenorg.geoserver.web:gs-appAffected: 2.25.0 up to 2.25.2; 2.0.0 up to 2.24.4Upgrade to 2.25.2 or later (older lines: 2.24.4)