Patchfirst
CVE-2024-45409 Public exploit Critical · 10.0 EPSS 10.7%

The Ruby SAML library vulnerable to a SAML authentication bypass via Incorrect XPath selector

SAML-Toolkits · ruby-saml

Summary

The Ruby SAML library (ruby-saml from SAML-Toolkits) does not properly verify the signature of SAML Responses in affected versions. The flaw lies in the library's client-side SAML authorization handling. An unauthenticated attacker with access to any document signed by the identity provider can forge a SAML Response or Assertion with arbitrary contents and log in as any user in the vulnerable system, requiring no authentication, user interaction, or special configuration beyond use of the affected library.

Official description · CVE.org

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

Breakdown
67.2 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 35 days after disclosure. Public exploit code (PoC-in-GitHub) appeared 27 days after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+27 days
  3. First seen exploitedVulnCheck KEV evidence+35 days

See the family tree

A fix was bypassed or incomplete once over 15 months. The latest fix listed for ruby-saml is 1.18.0.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2024-45409The Ruby SAML library vulnerable to a SAML authentication bypass…10 Sep 2024
  2. relatedHigh

    Why these are linked:

    CVE-2025-25291ruby-saml vulnerable to SAML authentication bypass due to…12 Mar 2025
  3. same family
    CVE-2025-25292Ruby SAML vulnerable to SAML authentication bypass due to…12 Mar 2025
  4. relatedMedium

    Why these are linked:

    CVE-2025-25293ruby-saml vulnerable to Remote Denial of Service (DoS) with…12 Mar 2025
  5. relatedMedium

    Why these are linked:

    CVE-2025-66567ruby-saml has a SAML authentication bypass due to namespace…9 Dec 2025
  6. relatedMedium

    Why these are linked:

    CVE-2025-66568ruby-saml Libxml2 Canonicalization errors can bypass…9 Dec 2025

Fixes in ruby-samlRubyGems package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 1.0.0CVE-2015-2010827 May 2023
  2. 1.3.0CVE-2016-569723 Jan 2017
  3. 1.7.0CVE-2017-1142817 Apr 2019
  4. 1.17.0CVE-2024-4540910 Sep 2024
  5. 1.18.0CVE-2025-2529112 Mar 2025
  6. 1.18.0CVE-2025-2529212 Mar 2025
  7. 1.18.0CVE-2025-2529312 Mar 2025Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: ruby-saml.

RubyGemsruby-samlGHSA-jw9c-mfg7-9rx2

Upgrade to 1.18.0 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2025-25292).

Gemfilegem "ruby-saml", ">= 1.18.0"

First fixed in 1.17.0 for CVE-2024-45409.

Affected versions, by release line

If you runUpgrade to
1.13.0 up to 1.17.01.18.0first fix for this CVE: 1.17.0
All versions before 1.12.31.12.4first fix for this CVE: 1.12.3

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 2 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

8 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close