Patchfirst
CVE-2025-23209 KEV High · 8.1 EPSS 21.6%

Craft CMS Code Injection Vulnerability

Craft CMS · Craft CMS

Summary

The flaw is a code injection vulnerability in Craft CMS (versions 4 and 5) that allows remote code execution. An attacker who holds a compromised security key can execute code on an unpatched Craft installation, with no authentication, user interaction, or special configuration indicated beyond that key being compromised.

Official description · NVD

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. Anyone running an unpatched version of Craft with a compromised security key is affected. This vulnerability has been patched in Craft 5.5.8 and 4.13.8. Users who cannot update to a patched version, should rotate their security keys and ensure their privacy to help migitgate the issue.

Breakdown
63.2 / 100
Exploited
Yes, in CISA KEV
Reports
0
Tactics
2/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

First seen exploited 1 day before it was disclosed.

  1. First seen exploitedVulnCheck KEV evidence1 day before
  2. Disclosedday 0
  3. Added to CISA KEVEU database agrees+33 days

CISA KEV listing is when exploitation was confirmed, not necessarily the first attack.

See the family tree

A fix was bypassed or incomplete once over 7 months. The latest fix listed for craftcms/cms is 5.7.5.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. This CVECVE-2025-23209Craft CMS Code Injection18 Jan 2025KEV
  2. bypassed the fixHigh

    Why these are linked:

    • Stated in the CVE textVersions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key".
    • Linked in OSV/GitHub advisoryGHSA-2vcf-qxv3-2mgw
    CVE-2025-54417Craft contains a theoretical bypass for CVE-⁠2025-⁠232099 Aug 2025

Fixes in craftcms/cmsPackagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 5.4.6CVE-2024-5229113 Nov 2024
  2. 5.4.9CVE-2024-5229213 Nov 2024
  3. 5.5.2CVE-2024-5614518 Dec 2024KEV
  4. 5.5.8CVE-2025-2320918 Jan 2025KEV
  5. 5.6.15CVE-2025-467315 May 2025
  6. 5.6.17CVE-2025-3243225 Apr 2025KEV
  7. 5.7.5CVE-2025-359397 May 2025KEVLatest listed

techniques

2 , grouped by in kill-chain order, 2 cited passages 2

Initial AccessTA0001

Exploit Public-Facing Application T1190 Medium
AI mapping from the description · how it is exploited

remote unauthenticated exploitation of public-facing CMS

This is an remote code execution (RCE) vulnerability that affects Craft 4 and 5 installs
From the official description (NVD) Original (opens in a new tab) ↗

ExecutionTA0002

Command and Scripting Interpreter T1059 Medium
AI mapping from the description · primary impact

RCE yields arbitrary command/code execution

remote code execution (RCE) vulnerability that affects Craft 4 and 5
From the official description (NVD) Original (opens in a new tab) ↗

Detection

0 rules for this CVE · 244 general rules for its techniques

Rules for this CVE

0 that reference CVE-2025-23209 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: craftcms/cms.

Packagistcraftcms/cmsGHSA-x684-96hh-833x

Upgrade to 5.7.5 or later

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2024-56145, CVE-2025-32432, +1).

Set the version to 5.7.5 or later in your composer.json.

First fixed in 5.5.8 for CVE-2025-23209.

Affected versions, by release line

If you runUpgrade to
5.0.0-RC1 up to 5.5.85.7.5first fix for this CVE: 5.5.8
4.0.0-RC1 up to 4.13.84.15.3first fix for this CVE: 4.13.8

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 50 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

4 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close