Patchfirst
CVE-2025-32432 KEVPublic exploit Critical · 10.0 EPSS 99.8%

Craft CMS Code Injection Vulnerability

Craft CMS · Craft CMS

Summary

Craft CMS, a content management system, contains a code injection flaw (CWE: improper control of generation of code) in versions 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17. An unauthenticated remote attacker over the network can achieve remote code execution with low complexity, requiring no privileges and no user interaction.

Official description · NVD

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

Breakdown
70.0 / 100
Exploited
Yes, in CISA KEV
Reports
0
Tactics
2/15

How an attack unfolds

Based on mappings. Select a step to see the evidence.
  1. How attackers get in

  2. What they do

First seen exploited 7 days before it was disclosed. Public exploit code (Metasploit) was available 11 days before disclosure.

  1. Public exploit codeMetasploit11 days before
  2. First seen exploitedVulnCheck KEV evidence7 days before
  3. Disclosedday 0
  4. Added to CISA KEVEU database agrees+11 mo

CISA KEV listing is when exploitation was confirmed, not necessarily the first attack.

See the family tree

A fix was bypassed or incomplete once over 19 months. The latest fix listed for craftcms/cms is 5.8.7.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2023-41892Craft CMS Remote Code Execution13 Sep 2023
  2. same family
    CVE-2024-56145Craft CMS Code Injection18 Dec 2024KEV
  3. Next fix in the same packageMedium

    Why these are linked:

    • Fixed one release later3.9.14 → 3.9.15 (craftcms/cms)
    • Similar weakness in the same product (machine-matched)same product + CWE + description similarity
    This CVECVE-2025-32432Craft CMS Code Injection25 Apr 2025KEV

Fixes in craftcms/cmsPackagist package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 5.5.2CVE-2024-5614518 Dec 2024KEV
  2. 5.5.8CVE-2025-2320918 Jan 2025KEV
  3. 5.6.15CVE-2025-467315 May 2025
  4. 5.6.17CVE-2025-3243225 Apr 2025KEV
  5. 5.7.5CVE-2025-359397 May 2025KEV
  6. 5.8.4CVE-2025-544179 Aug 2025
  7. 5.8.7CVE-2025-5781125 Aug 2025Latest listed

techniques

2 , grouped by in kill-chain order, 2 cited passages 2

Initial AccessTA0001

Exploit Public-Facing Application T1190 Medium
AI mapping from the description · how it is exploited

Remote unauthenticated attack against public-facing CMS

Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector
From the official description (NVD) Original (opens in a new tab) ↗

ExecutionTA0002

Command and Scripting Interpreter T1059 Medium
AI mapping from the description · primary impact

Code execution is the direct impact

Craft is vulnerable to remote code execution
From the official description (NVD) Original (opens in a new tab) ↗

Detection

0 rules for this CVE · 244 general rules for its techniques

Rules for this CVE

0 that reference CVE-2025-32432 directly.

CVE-specific rules are not available in this build. Search SigmaHQ ↗

Sigma rules © SigmaHQ, Detection Rule License 1.1; linked, not reproduced.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: craftcms/cms.

Packagistcraftcms/cmsGHSA-f3gw-9ww9-jmc3

Upgrade to 5.7.5 or later

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2024-56145, CVE-2025-23209, +1).

Set the version to 5.7.5 or later in your composer.json.

First fixed in 5.6.17 for CVE-2025-32432.

Affected versions, by release line

If you runUpgrade to
5.0.0-RC1 up to 5.6.175.7.5first fix for this CVE: 5.6.17
4.0.0-RC1 up to 4.14.154.15.3first fix for this CVE: 4.14.15
3.0.0-RC1 up to 3.9.15

Still affected on this line by CVE-2025-35939 (fixed in 4.15.3, a newer line).

3.9.15

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 50 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

7 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close