Patchfirst
CVE-2025-29891 Public exploit Medium · 4.8 EPSS 76.1%

Apache Camel: Camel Message Header Injection through request parameters

Apache Software Foundation · Apache Camel

Official description · CVE.org

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component. If you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers.  The headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation. All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box. This CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determined that it is also exploitable via HTTP parameters. Like in CVE-2025-27636, exploitation is only possible if the Camel route uses particular vulnerable components.

Breakdown
65.0 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 4 months after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+4 mo

2 related vulnerabilities in the same code over 3 days.

Linked vulnerabilitiesLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2025-27636Camel: Camel Message Header Injection via Improper Filtering9 Mar 2025
  2. relatedLow

    Why these are linked:

    • Stated in the CVE textThis CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determine…
    This CVECVE-2025-29891Camel: Camel Message Header Injection through request parameters12 Mar 2025

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.apache.camel:camel-support.

Mavenorg.apache.camel:camel-supportGHSA-96v5-c2h5-56hm

Upgrade to 4.10.2 or later

Fixes this CVE and 1 other known vulnerability in this package (CVE-2025-27636).

Set the version to 4.10.2 or later in your pom.xml or build.gradle.

The first fix for CVE-2025-29891.

Affected versions, by release line

If you runUpgrade to
4.9.0 up to 4.10.24.10.2
4.0.0-M1 up to 4.8.54.8.5
3.10.0 up to 3.22.43.22.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

Also mentioned in 5 community threat pulses (AlienVault OTX)

Weaker evidence

Pulses are indicator collections that anyone can publish. A mention is not confirmation of exploitation.

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close