Patchfirst
CVE-2025-29925 Public exploit High · 8.7 EPSS 0.9%

XWiki allows unregistered users to access private pages information through REST endpoint

xwiki · xwiki-platform

Official description · CVE.org

XWiki Platform is a generic wiki platform. Prior to 15.10.14, 16.4.6, and 16.10.0-rc-1, protected pages are listed when requesting the REST endpoints /rest/wikis/[wikiName]/pages even if the user doesn't have view rights on them. It's particularly true if the entire wiki is protected with "Prevent unregistered user to view pages": the endpoint would still list the pages of the wiki, though only for the main wiki. The problem has been patched in XWiki 15.10.14, 16.4.6, 16.10.0RC1. In those versions the endpoint can still be requested but the result is filtered out based on pages rights.

Breakdown
58.3 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 6 months after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+6 mo

7 fixes in xwiki-platform-rest-server over 2 years. The latest fix listed for xwiki-platform-rest-server is 17.4.2.

Fixes in xwiki-platform-rest-serverMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 15.2CVE-2023-3727710 Jul 2023
  2. 16.3.0-rc-1CVE-2024-4559110 Sep 2024
  3. 16.7.0CVE-2025-4655430 Apr 2025
  4. 16.10.0-rc-1CVE-2025-2992519 Mar 2025
  5. 16.10.1CVE-2025-3296923 Apr 2025
  6. 17.0.0CVE-2025-4958413 Jun 2025
  7. 17.4.2CVE-2025-524726 Oct 2025Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-rest-server.

Mavenorg.xwiki.platform:xwiki-platform-rest-serverGHSA-22q5-9phm-744v

Upgrade to 16.4.6

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2025-32969, CVE-2025-46554).

Still affected on this line by CVE-2025-52472 (fixed in 16.10.9, a newer line).

Also affected, despite being newer: 16.5.0-rc-1 up to 16.10.0-rc-1.

Set the version to 16.4.6 or later in your pom.xml or build.gradle.

The first fix for CVE-2025-29925.

Affected versions, by release line

If you runUpgrade to
16.5.0-rc-1 up to 16.10.0-rc-116.10.9first fix for this CVE: 16.10.0-rc-1
16.0.0-rc-1 up to 16.4.616.4.6
1.9M1 up to 15.10.14

Still affected on this line by CVE-2025-52472 (fixed in 16.10.9, a newer line).

15.10.16first fix for this CVE: 15.10.14

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

5 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close