Patchfirst
CVE-2025-46554 Public exploit Medium · 5.3 EPSS 1.1%

XWiki missing authorization when accessing the wiki level attachments list and metadata via REST API

xwiki · xwiki-platform

Official description · CVE.org

XWiki is a generic wiki platform. In versions starting from 1.8.1 to before 14.10.22, from 15.0-rc-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.7.0, anyone can access the metadata of any attachment in the wiki using the wiki attachment REST endpoint. There is no filtering for the results depending on current user rights, meaning an unauthenticated user could exploit this even in a private wiki. This issue has been patched in versions 14.10.22, 15.10.12, 16.4.3, and 16.7.0.

Breakdown
56.7 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 4 months after disclosure.

  1. Disclosedday 0
  2. First seen exploitedVulnCheck KEV evidence+4 mo

7 fixes in xwiki-platform-rest-server over 24 months. The latest fix listed for xwiki-platform-rest-server is 17.0.0.

Fixes in xwiki-platform-rest-serverMaven package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 15.1CVE-2023-3515123 Jun 2023
  2. 15.2CVE-2023-3727710 Jul 2023
  3. 16.3.0-rc-1CVE-2024-4559110 Sep 2024
  4. 16.7.0CVE-2025-4655430 Apr 2025
  5. 16.10.0-rc-1CVE-2025-2992519 Mar 2025
  6. 16.10.1CVE-2025-3296923 Apr 2025
  7. 17.0.0CVE-2025-4958413 Jun 2025Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-rest-server.

Mavenorg.xwiki.platform:xwiki-platform-rest-serverGHSA-r5cr-xm48-97xp

Upgrade to 16.10.9 or later

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2025-29925, CVE-2025-32969, +1).

Set the version to 16.10.9 or later in your pom.xml or build.gradle.

First fixed in 16.7.0 for CVE-2025-46554.

Affected versions, by release line

If you runUpgrade to
16.5.0-rc-1 up to 16.7.016.10.9first fix for this CVE: 16.7.0
16.0.0-rc-1 up to 16.4.3

Still affected on this line by CVE-2025-52472 (fixed in 16.10.9, a newer line).

16.4.6first fix for this CVE: 16.4.3
15.0-rc-1 up to 15.10.12

Still affected on this line by CVE-2025-52472 (fixed in 16.10.9, a newer line).

15.10.16first fix for this CVE: 15.10.12
1.8.1 up to 14.10.22

Still affected on this line by CVE-2025-29925 (fixed in 15.10.14, a newer line); CVE-2025-32969 (fixed in 15.10.16, a newer line); CVE-2025-52472 (fixed in 16.10.9, a newer line).

14.10.22

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

5 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close