Patchfirst
CVE-2025-32429 Public exploit Critical · 9.3 EPSS 85.5%

XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter

xwiki · xwiki-platform

Summary

The XWiki Platform (xwiki-platform) has an SQL injection flaw in the sort parameter of its getdeleteddocuments.vm template, where the value is inserted unmodified as an ORDER BY clause. An attacker with network access can exploit it without authentication or user interaction, with no special configuration needed, to read, modify, or disrupt the underlying database.

Official description · CVE.org

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 9.4-rc-1 through 16.10.5 and 17.0.0-rc-1 through 17.2.2, it's possible for anyone to inject SQL using the parameter sort of the getdeleteddocuments.vm. It's injected as is as an ORDER BY value. This is fixed in versions 16.10.6 and 17.3.0-rc-1.

Breakdown
71.5 / 100
Exploited
Yes, in VulnCheck KEV
Reports
0
Tactics
0/15

First seen exploited 3 months after disclosure. Public exploit code (PoC-in-GitHub) appeared 1 day after disclosure.

  1. Disclosedday 0
  2. Public exploit codePoC-in-GitHub+1 day
  3. First seen exploitedVulnCheck KEV evidence+3 mo

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: org.xwiki.platform:xwiki-platform-distribution-war.

Mavenorg.xwiki.platform:xwiki-platform-distribution-warGHSA-vr59-gm53-v7cq

Upgrade to 16.10.6

Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2023-29525, CVE-2023-32071).

Also affected, despite being newer: 17.0.0-rc-1 up to 17.3.0-rc-1.

Set the version to 16.10.6 or later in your pom.xml or build.gradle.

The first fix for CVE-2025-32429.

Affected versions, by release line

If you runUpgrade to
17.0.0-rc-1 up to 17.3.0-rc-117.3.0-rc-1
9.4-rc-1 up to 16.10.616.10.6

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

4 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close