Upgrade to 2.555.3 or later
Fixes this CVE and 4 other known vulnerabilities in this package (CVE-2024-23897, CVE-2024-23898, +2).
Set the version to 2.555.3 or later in your pom.xml or build.gradle.
First fixed in 2.252 for CVE-2020-2230.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 2.236 up to 2.252 | 2.555.3first fix for this CVE: 2.252 |
| All versions before 2.235.4 Still affected on this line by CVE-2024-23897 (fixed in 2.426.3, a newer line); CVE-2024-23898 (fixed in 2.426.3, a newer line); CVE-2025-59474 (fixed in 2.516.3, a newer line); CVE-2026-53435 (fixed in 2.555.3, a newer line). | 2.235.4 |
“Up to” means the second version is the fix and is not affected.