Upgrade to 10.0.22
Fixes this CVE and 4 other known vulnerabilities in this package (CVE-2020-13934, CVE-2020-13935, +2).
Also affected, despite being newer: 10.1.0-M1 up to 10.1.0-M15.
Set the version to 10.0.22 or later in your pom.xml or build.gradle.
First fixed in 10.0.21 for CVE-2022-29885.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 10.1.0-M1 up to 10.1.0-M15 | 10.1.45first fix for this CVE: 10.1.0-M15 |
| 10.0.0-M1 up to 10.0.21 | 10.0.22first fix for this CVE: 10.0.21 |
| 9.0.13 up to 9.0.63 | 9.0.109first fix for this CVE: 9.0.63 |
| 8.5.38 up to 8.5.79 Still affected on this line by CVE-2025-55752 (no fix published). | 8.5.82first fix for this CVE: 8.5.79 |
“Up to” means the second version is the fix and is not affected.