Patchfirst
CVE-2022-4223 Public exploit High · 8.8 EPSS 80.1%

The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external…

Summary

The pgAdmin server's HTTP API for validating paths to external PostgreSQL utilities such as pg_dump and pg_restore, which the server executes to determine the PostgreSQL version, failed to properly restrict access in versions prior to 6.17. An attacker who can reach the API without authentication and get a user to interact with the request can supply a path of their choosing, such as a UNC path to a server they control on Windows, causing an executable with a matching name in that location to run on the pgAdmin server.

Official description · CVE.org

The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.

Breakdown
31.1 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Disclosed on 13 Dec 2022. No public exploit code or confirmed exploitation is recorded.

6 fixes in pgadmin4 over 3 years. The latest fix listed for pgadmin4 is 7.7.

Fixes in pgadmin4PyPI package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 6.7CVE-2022-095916 Mar 2022
  2. 6.14CVE-2023-2229817 Jan 2023
  3. 6.17CVE-2022-422313 Dec 2022
  4. 6.19CVE-2023-024127 Mar 2023
  5. 7.0CVE-2023-19079 Jan 2025
  6. 7.7CVE-2023-500222 Sep 2023Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: pgadmin4.

Upgrade to 6.17

Still affected on this line by CVE-2024-2044 (fixed in 8.4, a newer line); CVE-2024-3116 (fixed in 8.5, a newer line); CVE-2024-9014 (fixed in 8.12, a newer line); CVE-2025-2945 (fixed in 9.2, a newer line).

pippip install "pgadmin4>=6.17"

The first fix for CVE-2022-4223.

Affected versions

If you runUpgrade to
All versions before 6.176.17

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

2 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close