Patchfirst
CVE-2024-3116 Public exploit High · 7.4 EPSS 65.8%

Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4

pgadmin.org · pgAdmin 4

Summary

pgAdmin 4 versions up to and including 8.4 contain a command injection flaw in the validate binary path API, which allows arbitrary code to be executed on the server hosting pgAdmin. An attacker who can reach the API over the network and holds low-privilege authenticated access can trigger the flaw without any user interaction, with the code running in the context of the pgAdmin server.

Official description · CVE.org

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

Breakdown
30.0 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Metasploit) was available 7 days before disclosure.

  1. Public exploit codeMetasploit7 days before
  2. Disclosedday 0

See the family tree

A fix was bypassed or incomplete once over 5 years. The latest fix listed for pgadmin4 is 9.2.

Same bug familyLinked by evidence that a fix failed or the same code was patched again. Oldest first.

  1. CVE-2022-0959A malicious, but authorised and authenticated user can construct…16 Mar 2022
  2. same family
    This CVECVE-2024-3116Remote Code Execution Vulnerability through the validate binary…4 Apr 2024
  3. relatedHigh

    Why these are linked:

    • Fixed one release later8.5 → 8.6 (pgadmin4)
    • Same code patched: __init__.py (machine-matched)Functions: validate_binary_pathcommit fbbbfe2commit f4761f5
    CVE-2024-4215The Multi Factor Authentication bypass vulnerability in pgAdmin…2 May 2024
  4. same family
    CVE-2024-4216XSS vulnerability in /settings/store API response json payload…2 May 2024
  5. same family
    CVE-2026-17566pgAdmin 4: RCE via backslash-escape mismatch in Import/Export…31 Jul 2026
  6. bypassed the fixHigh

    Why these are linked:

    • Stated in the CVE textThis is a bypass of the fix for CVE-2026-17566.
    CVE-2026-116241pgAdmin 4's Import/Export Data tool wraps a user's query export…30 Oct 2026

Fixes in pgadmin4PyPI package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 6.19CVE-2023-024127 Mar 2023
  2. 7.0CVE-2023-19079 Jan 2025
  3. 7.7CVE-2023-500222 Sep 2023
  4. 8.5CVE-2024-31164 Apr 2024
  5. 8.6CVE-2024-42152 May 2024
  6. 8.12CVE-2024-901423 Sep 2024
  7. 9.2CVE-2025-29453 Apr 2025Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: pgadmin4.

Upgrade to 8.12

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2022-4223, CVE-2024-2044, +1).

Still affected on this line by CVE-2025-2945 (fixed in 9.2, a newer line).

pippip install "pgadmin4>=8.12"

First fixed in 8.5 for CVE-2024-3116.

Affected versions

If you runUpgrade to
All versions before 8.58.12first fix for this CVE: 8.5

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

4 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close