Patchfirst
CVE-2024-2044 Public exploit Critical · 9.9 EPSS 79.5%

Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4

pgadmin.org · pgAdmin 4

Official description · CVE.org

pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.

Breakdown
31.9 / 100
Exploited
Not confirmed
Reports
0
Tactics
0/15

Public exploit code (Metasploit) was available 3 days before disclosure.

  1. Public exploit codeMetasploit3 days before
  2. Disclosedday 0

2 fixes in pgAdmin4 over 8 weeks. The latest fix listed for pgAdmin4 is 8.6.

Fixes in pgAdmin4PyPI package, by fixed version. Earlier and later fixes in the same package, not necessarily the same bug.

  1. 8.4CVE-2024-20447 Mar 2024
  2. 8.6CVE-2024-42162 May 2024Latest listed

techniques

No techniques linked

No ATT&CK techniques are linked to this CVE yet. MITRE CTID has not mapped it, and no report passage in the corpus ties it to a technique.

Am I affected? What do I upgrade to?

From GitHub Security Advisories and OSV

1 package in 1 ecosystem. Main package: pgAdmin4.

Upgrade to 8.12

Fixes this CVE and 3 other known vulnerabilities in this package (CVE-2022-4223, CVE-2024-3116, +1).

Still affected on this line by CVE-2025-2945 (fixed in 9.2, a newer line).

pippip install "pgAdmin4>=8.12"

First fixed in 8.4 for CVE-2024-2044.

Affected versions

If you runUpgrade to
All versions before 8.48.12first fix for this CVE: 8.4

“Up to” means the second version is the fix and is not affected.

Check your lockfile against all CVEs

What security researchers reported

Not named in any threat report yet

References

3 links, grouped by NVD tag
↑ ↓ chooseEnter openEsc close