Upgrade to 1.642.2
Fixes this CVE and 2 other known vulnerabilities in this package (CVE-2015-5317, CVE-2016-0792).
Still affected on this line by CVE-2016-9299 (fixed in 2.19.3, a newer line); CVE-2017-1000353 (fixed in 2.46.2, a newer line); CVE-2018-1000861 (fixed in 2.138.4, a newer line); CVE-2018-1999002 (fixed in 2.121.2, a newer line); CVE-2019-10405 (fixed in 2.176.4, a newer line); CVE-2020-2230 (fixed in 2.235.4, a newer line); CVE-2024-23897 (fixed in 2.426.3, a newer line); CVE-2025-59474 (fixed in 2.516.3, a newer line); CVE-2026-53435 (fixed in 2.555.3, a newer line).
Set the version to 1.642.2 or later in your pom.xml or build.gradle.
First fixed in 1.498 for CVE-2013-0158.
Affected versions, by release line
| If you run | Upgrade to |
|---|---|
| 1.481 up to 1.498 | 1.642.2first fix for this CVE: 1.498 |
| All versions before 1.480.2 Still affected on this line by CVE-2015-5317 (fixed in 1.625.2, a newer line); CVE-2016-0792 (fixed in 1.642.2, a newer line); CVE-2016-9299 (fixed in 2.19.3, a newer line); CVE-2017-1000353 (fixed in 2.46.2, a newer line); CVE-2018-1000861 (fixed in 2.138.4, a newer line); CVE-2018-1999002 (fixed in 2.121.2, a newer line); CVE-2019-10405 (fixed in 2.176.4, a newer line); CVE-2020-2230 (fixed in 2.235.4, a newer line); CVE-2025-59474 (fixed in 2.516.3, a newer line); CVE-2026-53435 (fixed in 2.555.3, a newer line). | 1.480.2 |
“Up to” means the second version is the fix and is not affected.